Slowness Logging into Apex Courses and Tutorials

Incident Report for Edmentum

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 11:30 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2025 - 11:26 CDT

Investigating

We are currently investigating reports of slowness logging into Apex Courses and Tutorials.
Posted Jun 03, 2025 - 11:06 CDT
This incident affected: Apex Learning (Apex Courses, Apex Tutorials).