Exact Path issue
Incident Report for
Edmentum
Resolved
This incident has been resolved.
Posted
Apr
23
,
2025
-
07:52
CDT
Update
We are continuing to monitor for any further issues.
Posted
Apr
23
,
2025
-
07:45
CDT
Monitoring
Teams have implemented a fix for the issue and are monitoring the results.
Posted
Apr
23
,
2025
-
07:44
CDT
Update
We are continuing to work on a fix for this issue.
Posted
Apr
23
,
2025
-
07:25
CDT
Identified
An issue preventing login to the platform has been identified. Teams are working on resolving the issue.
Posted
Apr
23
,
2025
-
07:21
CDT
This incident affected: Courseware and Exact Path.
×
Subscribe to Incident
Subscribe to updates for
Exact Path issue
via . You'll receive .