Study Island Performance Issues

Incident Report for Edmentum

Resolved

This incident has been resolved. We will continue to the monitor Study Island's performance.
Posted Apr 23, 2026 - 09:53 CDT

Monitoring

A fix has been implemented, and we are seeing the platform return to expected performance levels. We will continue to monitor.
Posted Apr 23, 2026 - 09:29 CDT

Identified

We are working to resolve issues loading the Study Island platform. The root cause has been identified and we are actively working to implement a fix.
Posted Apr 23, 2026 - 07:15 CDT
This incident affected: Study Island.