Apex Gradebook Slowness
Incident Report for Edmentum
Resolved
This incident has been resolved.
Posted Aug 29, 2024 - 16:19 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 29, 2024 - 16:13 CDT
Investigating
We are currently investigating reports of users experiencing slow response times within Apex Gradebook
Posted Aug 29, 2024 - 15:53 CDT
This incident affected: Apex Learning (Apex Courses).