Courseware - Personal Psychology 1 Launch Issue

Incident Report for Edmentum

Resolved

This issue has been resolved. We will continue to monitor the courses performance.
Posted Apr 14, 2026 - 13:33 CDT

Investigating

We are currently investigating and issue launching the Personal Psychology 1 course. At this time, the issues are isolated to this course.
Posted Apr 14, 2026 - 12:36 CDT
This incident affected: Courseware.