Performance Issues: MajorClarity

Incident Report for Edmentum

Resolved

This incident has been resolved. We will continue to monitor the performance to the platform.
Posted Jan 08, 2026 - 12:29 CST

Monitoring

We have implemented a fix and performance has improved as expected. We will continue to monitor the performance to the platform.
Posted Jan 08, 2026 - 12:17 CST

Identified

We have identified the root cause and are working to remediate the issue.
Posted Jan 08, 2026 - 11:23 CST

Update

We are continuing to investigate this issue.
Posted Jan 08, 2026 - 11:09 CST

Investigating

We are currently investigating reports concerning issues logging into the MajorClarity platform.
Posted Jan 08, 2026 - 10:45 CST
This incident affected: MajorClarity.