Courseware and Exact Path Performance Issues

Incident Report for Edmentum

Resolved

This incident has been resolved. We will continue to monitor the performance of the platform.
Posted Apr 25, 2026 - 19:20 CDT

Identified

The root cause has been identified, and we are working to resolve the issue.
Posted Apr 25, 2026 - 19:12 CDT

Investigating

We are currently investigating performance issues with the Courseware and Exact Path platforms.
Posted Apr 25, 2026 - 18:45 CDT
This incident affected: Courseware and Exact Path.