Exact Path and Courseware Learners Unable to Login

Incident Report for Edmentum

Resolved

This incident has been resolved. However, if you or your students experience any ongoing issues, please contact us at 1-800-447-5286, support@edmentum.com, or via chat.
Posted Sep 25, 2025 - 09:00 CDT

Investigating

Exact Path and Courseware are experiencing issues whereby Learners are unable to login to ELF.

Teams are investigating and working to restore normal service as quickly as possible.
Posted Sep 25, 2025 - 08:37 CDT
This incident affected: Courseware and Exact Path.