Study Island Degraded Performance
Incident Report for Edmentum
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 09:55 CDT
Monitoring
We have identified the source if the issue and have implemented a fix to stabilize performance. We will continue to monitor performance to ensure the issue does not persist.
Posted Apr 11, 2024 - 08:53 CDT
Investigating
We are currently investigating an issue regarding degraded performance with Study Island.
Posted Apr 11, 2024 - 08:40 CDT
This incident affected: Study Island.