Apex Learning Login Issues
Incident Report for Edmentum
Resolved
This incident has been resolved.
Posted May 18, 2023 - 11:52 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 18, 2023 - 11:39 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 18, 2023 - 11:33 CDT
Investigating
We are currently investigating an issue regarding the ability to login to Apex Learning. Users may receive a "Session Expired" message.
Posted May 18, 2023 - 11:18 CDT
This incident affected: Apex Learning (Apex Courses, Apex Tutorials).