Performance issues: Apex Courses and Tutorials
Incident Report for
Edmentum
Resolved
This incident has been resolved. We will continue to monitor the performance to the platform.
Posted
Aug
21
,
2025
-
13:26
CDT
Identified
We have identified the root cause and implemented a fix. We will continue to monitor the performance of the platform.
Posted
Aug
21
,
2025
-
12:35
CDT
Investigating
We are currently investigating loading issues for teachers on the Apex Learning platform. This affects both Courses and Tutorials.
Posted
Aug
21
,
2025
-
12:21
CDT
This incident affected: Apex Learning (Apex Courses, Apex Tutorials).
×
Subscribe to Incident
Subscribe to updates for
Performance issues: Apex Courses and Tutorials
via . You'll receive .