Support Emails not Delivered
Incident Report for Edmentum
Resolved
This incident has been resolved.
Posted Mar 05, 2021 - 13:30 CST
Monitoring
The cause of the issue has been identified and steps to remediate have been taken. Mail is flowing as expected but we will continue to monitor the situation.
Posted Mar 05, 2021 - 13:16 CST
Investigating
We are investigating reports of non-delivery to our Support email addresses. Please visit our support site for the other options we have to contact our Support Team.

https://www.edmentum.com/support
Posted Mar 05, 2021 - 12:30 CST
This incident affected: Edmentum Support (Web and Phone).